January 2014

TeXnicle and Snow Leopard support

  • To all Snow Leopard users: you will have noticed that the last two releases of TeXnicle have an issue on 10.6.8 which stops the PDF from being updated. The only way to get it to update (after a build) is to resize the window or to zoom in and out. Far from ideal. The problem arises from the fact that these latest releases of TeXnicle are built on Mavericks, and even though all the build settings are correct to maintain compatibility with Snow Leopard, nonetheless this bug appears. This must be due to some underlying changes in PDFKit which provides the PDF view that’s used.
  • After long discussions with two Apple engineers, there seems to be no solution to this. Apple only supports backwards compatibility back two major versions, so Snow Leopard falls outside this.
  • Since I can’t possibly support two different build systems and two different releases of TeXnicle, I think the only way forward is to hope someone in the community is willing to take on building and releasing TeXnicle for Snow Leopard. To do that, they will need a running 10.8 (or earlier) system with all the necessary build tools. TeXnicle is already open source and is available on Git Hub (https://github.com/martinhewitson/TeXnicle).
  • Comments?